Account Center Maintenance
Incident Report for VoicePulse
Resolved
Issues updating credit cards or making payments are now resolved across all VoicePulse services. The root cause was the disabling of SSL/TLS by our payment processor. We are now using the recommended version (TLS 1.2) for all transactions.
Posted Mar 03, 2018 - 20:27 EST
Identified
The VoicePulse Connect and Home account centers are under maintenance to resolve an issue with our payment provider.
Posted Mar 03, 2018 - 16:23 EST