Upstream Carrier issue affecting inbound calls to Miami FL
Incident Report for VoicePulse
Resolved
Carrier reports this issue should be resolved,
If you are still having an issue with any Miami or Florida numbers please contact support at 732-339-5100
Posted Nov 20, 2018 - 14:29 EST
Identified
VoicePulse has become aware of an upstream carrier issue affecting inbound calls to Miami Florida and surrounding areas.
No ETA at this time.

Follow this page for further updates.
Posted Nov 19, 2018 - 13:36 EST