Legacy Residential inbound and Outbound calling issue
Incident Report for VoicePulse
Resolved
The upstream issue affecting some of our Legacy Residential customers has been resolved.

If you continue to have an issue with your Legacy Residential service, please email support at contact@voicepulse.com
Posted Sep 26, 2019 - 11:57 EDT
Investigating
VoicePulse is currently investigating an issue with some legacy residential customers being unable to make or receive calls.

Please check back on this page for further updates as we work to resolve the issue.
Posted Sep 26, 2019 - 10:26 EDT
This incident affected: VoicePulse for Home.