Hosted PBX Outage
Incident Report for VoicePulse
Resolved
The issue has been resolved.
It may take up to 30 minutes for all service to be restored.
If you are still having an issue after this time, make sure you have rebooted your phone.
Unplug the phone and leave it unplugged for 10-15 seconds then plug it back in to reboot.

If issues persist please contact support at contact@voicepulse.com
Posted Oct 22, 2018 - 17:06 EDT
Identified
We are working on restoring voice services to the remaining Hosted PBX customers that are impacted.
Posted Oct 22, 2018 - 16:31 EDT
Investigating
We are investigating outage reports on our Hosted PBX platform for some users.
Posted Oct 22, 2018 - 12:20 EDT
This incident affected: VoicePulse Hosted PBX.