Hosted PBX Portal Unavailable
Incident Report for VoicePulse
Resolved
This issue has been resolved.
Posted Oct 22, 2018 - 18:08 EDT
Identified
We are still working to resolve the Hosted PBX portal issue.
This issue is unrelated to the partial outage issue which has been resolved.
Posted Oct 22, 2018 - 17:32 EDT
This incident affected: VoicePulse Hosted PBX.